SDG&E Power Outage | Carlsbad
Incident Report for Downtown Works
Resolved
SDG&E has restored power to the area. We will continue to monitor for outages. Thank you for your patience.
Posted Jun 29, 2023 - 11:09 PDT
Identified
SDG&E is currently investigating a power outage in Carlsbad. More information is available below

https://www.sdge.com/residential/customer-service/outage-center/outage-map
Posted Jun 29, 2023 - 10:13 PDT
This incident affected: Internet & WIFI (Carlsbad) and Access Control (SWITCH Mobile Access).