Internet Service Issues | Degraded Performance
Incident Report for Downtown Works
Resolved
We are marking this incident as resolved.
Posted Feb 12, 2024 - 17:24 PST
Monitoring
All systems are normal and we have been unable to pinpoint any root cause of this issue. We will continue monitoring for any additional issues or elevated user reported issues. If you continue to experience issues, please email support@downtownworks.com.
Posted Feb 12, 2024 - 15:29 PST
Update
We are continuing to investigate this issue.
Posted Feb 12, 2024 - 14:25 PST
Investigating
We are looking into reports of WIFI issues for a select number of users.
Posted Feb 12, 2024 - 13:25 PST
This incident affected: Internet & WIFI (Carlsbad, Pacific Beach).