SDG&E Unplanned Power Outage | Mission Valley

Incident Report for Downtown Works

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 01:07 PDT

Update

Systems have come online and we will continue to monitor for any additional outages.
Posted Jun 30, 2025 - 18:36 PDT

Monitoring

There is currently an unplanned power outage in Mission Valley affecting all our systems. For more information visit sdge.com/outages
Posted Jun 30, 2025 - 18:20 PDT
This incident affected: Access Control (SWITCH Mobile Access) and Internet & WIFI (Mission Valley).