ezeep Service Issues
Incident Report for Downtown Works
Resolved
All services are back online. For more information, please visit status.ezeep.com
Posted Mar 23, 2023 - 14:05 PDT
Investigating
ezeep is currently experiencing issues with their services. For more information, please visit status.ezeep.com
Posted Mar 23, 2023 - 13:55 PDT
This incident affected: Member Portal, Website, Online Services (ezeep Platform).