Guest WIFI Splash Page | All Locations
Incident Report for Downtown Works
Resolved
This incident has been resolved and we will continue to monitor. Thank you for your patience.
Posted Jul 25, 2023 - 11:39 PDT
Identified
The issue has been identified and our partner is pushing a fix.
Posted Jul 25, 2023 - 11:37 PDT
Investigating
Some users are currently experiencing issues logging into our Guest network. We are investigating this issue.
Posted Jul 25, 2023 - 11:31 PDT
This incident affected: Internet & WIFI (Splash Pages).