ezeep Service Issues | Little Italy
Incident Report for Downtown Works
Resolved
Maintenance is completed and all systems are normal.
Posted Oct 02, 2023 - 10:23 PDT
Identified
We identified an issue affecting our Little Italy location and are currently performing maintenance.
Posted Oct 02, 2023 - 10:11 PDT
This incident affected: Member Portal, Website, Online Services (ezeep Platform).