ezeep Service Degradation
Incident Report for Downtown Works
Resolved
All printers are online and we will continue to monitor the situation.
Posted Apr 10, 2023 - 11:45 PDT
Identified
The issue has been identified, and we are applying a fix.
Posted Apr 10, 2023 - 11:08 PDT
Investigating
We are currently investigating issues that members are unable to print at all locations.
Posted Apr 10, 2023 - 10:22 PDT
This incident affected: Member Portal, Website, Online Services (ezeep Platform).