Splash Page Connection Errors

Incident Report for Downtown Works

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 11:52 PDT

Monitoring

We have identified an issue with our Splash pages and reverted a change we made yesterday. We will continue to monitor.
Posted Oct 09, 2025 - 09:12 PDT

Investigating

We are currently investigating issues with our Splash pages not loading correctly.
Posted Oct 09, 2025 - 09:03 PDT
This incident affected: Internet & WIFI (Splash Pages).