SWITCH Mobile Access Android Errors
Incident Report for Downtown Works
Resolved
Any Android user with the Best Switch app installed should go to the Google Play Store on their phone and download the update.

Once updated, the app will continue crash on launch until the following steps are done:

- Go to Settings
- Tap on Apps
- Locate Switch in the Apps list
- Tap on Switch
- On the App Info screen, tap on permissions
- On the Permissions Screen, tap Nearby Devices
- On the Nearby devices permissions Screen tap Allow

The Switch App will start working properly once the Nearby Devices Permission is set to Allow.
Posted Mar 10, 2023 - 14:31 PST
Monitoring
The app developer has identified and are working on resolving an issue with The Switch™ Tech App caused by a recent Android OS update. We identified a user enabled change that will allow the mobile device to work again in most cases.

Go to the “App Info” in Settings.
Select Switch
Tap on “Permissions”
Tap on “Nearby Devices”
Tap on “Allow”

They are continuing to work with the Google Play Store to address the situation in a timely fashion. The recommendation is if you are prompted to update your Android device to wait a few days before doing so. We apologize for the inconvenience this has caused our members.
Posted Mar 10, 2023 - 10:00 PST
Identified
Earlier today there was a reported issue affecting Android users of the SWITCH mobile app. This is due to a recent update. Since this morning, the Switch Tech Android problem has been resolved, the release is pending Google approval. Once released, users can update to the latest version. This should hopefully be released very soon. We will update you once the Google Play store has the new release for the end users. If you are able to rollback to a previous version, this will allow you to have access. We apologize for any inconvenience this may cause.
Posted Mar 09, 2023 - 16:06 PST
This incident affected: Access Control (SWITCH Mobile Access).