Power Outage
Incident Report for Downtown Works
Resolved
This incident has been resolved.
Posted Jan 26, 2023 - 11:11 PST
Monitoring
Power has been restored and we are monitoring the results closely.
Posted Jan 26, 2023 - 11:02 PST
Update
SDG&E is attempting to restore power to affected communities.
Posted Jan 26, 2023 - 10:15 PST
Identified
There is currently a power outage affecting our Downtown location. For more outage information please visit sdge.com/outagemap.
Posted Jan 26, 2023 - 10:14 PST
This incident affected: Internet & WIFI (San Diego) and Access Control (Brivo).